---
title: 快速恢复的租户限制-OceanBase数据库使用指南
description: 了解OceanBase数据库在实际应用中关于快速恢复的租户限制相关的常见问题和使用技巧，帮助您快速解决快速恢复的租户限制的难题。
image: https://mdn.alipayobjects.com/huamei_22khvb/afts/img/A*OSPzQ6GUQF4AAAAAQHAAAAgAeiGDAQ/original
---
切换语言

- 中文站 - 简体中文
- International - English
- 日本站 - 日本語

划线反馈

# 快速恢复的租户限制

更新时间：2026-06-10 02:41

适用版本： V4.0.x、V4.1.x、V4.2.x、V4.3.x 内容类型：TechNote  

## 问题描述

已备份的生产数据，在测试数据库中还原后，提示 `standby tenant is read only`。

执行切主命令

```shell
obclient> ALTER SYSTEM ACTIVATE STANDBY TENANT mq_t1;

```

出现报错

```shell
4179 - Tenant restore data mode is remote. Operation is not allowed

```

## 问题原因

通过快速恢复方式恢复出来的租户不支持手动发起合并，不支持数据备份，也不支持 Switchover/Failover 成主库，只能作为备库存在。

## 适用版本

OceanBase 数据库 V4.x 版本

Previous

[通过拷贝出来的备份进行租户物理恢复时恢复进度一直卡在“恢复中”状态的原因和解决方法](https://www.oceanbase.com/knowledge-base/oceanbase-database-1000000003100051)

Next

[Restore 单表失败](https://www.oceanbase.com/knowledge-base/oceanbase-database-1000000000207688) ![有帮助](https://gw.alipayobjects.com/mdn/ob_asset/afts/img/A*y6ocSqN8cqsAAAAAAAAAAAAAARQnAQ)![无帮助](https://gw.alipayobjects.com/mdn/ob_asset/afts/img/A*BG9IQJyLHF8AAAAAAAAAAAAAARQnAQ)![反馈](https://gw.alipayobjects.com/mdn/ob_asset/afts/img/A*eTWdQKCRKHwAAAAAAAAAAAAAARQnAQ)[AI](https://www.oceanbase.com/obi) 咨询热线
