适用版本
OceanBase 数据库 V2.x 和 V3.x 版本。
问题现象
恢复数据过程中(ALTER SYSTEM RESTORE ...),命令正常返回,但恢复不成功。
使用 root 用户登录数据库的 SYS 租户,通过下述命令查看恢复历史任务信息。
obclient> select * from __all_restore_history;
OB_LOG_ARCHIVE_BACKUP_INFO_NOT_EXIST 报错信息如下。
ROOTSERVICE : OB_ISOLATED_BACKUP_SET(-9048) on "10.xxx.xx.xx:32882" with traceid Y80720A894711-0005ECCD1C82DBEB-0-0
OB_ISOLATED_BACKUP_SET 报错信息如下。
ROOTSERVICE : OB_LOG_ARCHIVE_BACKUP_INFO_NOT_EXIST(-9025) on "10.xxx.xx.xx:32882" with traceid Y80720A894711-0005ECCD1C82DBFD-0-0
OB_RESOURCE_POOL_NOT_EXIST 报错信息如下。
ROOTSERVICE : OB_RESOURCE_POOL_NOT_EXIST(-4650) on "10.xxx.xx.xx:32882" with traceid Y80720A894711-0005ECCD1C82DC09-0-0
问题原因
报错原因:
OB_LOG_ARCHIVE_BACKUP_INFO_NOT_EXIST:log 找不到,可能是恢复时间大于日志归档的时间导致。
OB_ISOLATED_BACKUP_SET:日志和备份集之间有断流。
OB_RESOURCE_POOL_NOT_EXIST:指定的资源池不存在。
解决方法
针对不同的报错,采用对应的手段处理。
处理建议:
报
OB_LOG_ARCHIVE_BACKUP_INFO_NOT_EXIST错误,建议修改恢复的时间点,确认其在日志归档时间之内。报
OB_ISOLATED_BACKUP_SET错误,建议在此轮日志归档上,重新执行数据全量备份。报
OB_RESOURCE_POOL_NOT_EXIST错误,需确认流程步骤无误,相应的资源池已成功创建。