基于湖库一体架构,统一管理结构化、半结构化与非结构化等多模态数据,一个系统承载事务处理、实时分析与 AI 工作负载。
连接 OceanBase 数据库租户报 access denied
更新时间:2024-03-29 06:46
本文介绍连接 OceanBase 数据库租户报 access denied 的原因和解决方法。
问题描述
连接 OceanBase 数据库时报如下错误。
ERROR 1227 (42501): Access denied
observer.log 日志提示如下。
WARN [SHARE.SCHEMA] is_in_white_list (ob_schema_struct.cpp:11055) [62805][0][xxxxx] [lt=20] [dc=0] client ip is not in ip_white_list(client_ip=1.2.3.4, orig_ip_white_list=127.0.0.1)
适用版本
OceanBase 数据库 V2.x 和 V3.x 版本。
问题原因
租户白名单未设置百分号 %。
解决方法
使用 IP 地址 127.0.0.1 方式,登录对应租户。
示例 OBClient 连接 OceanBase 数据库的 MySQL 模式租户:
$ obclient -h127.0.0.1 -P3306 -u a**** -p****** -c -A -Doceanbase执行如下 SQL 设置租户白名单。
obclient> SET GLOBAL ob_tcp_invited_nodes='%';ob_tcp_invited_nodes用于设置租户的 IP 白名单,详细信息参见 ob_tcp_invited_nodes。重新尝试连接。