基于湖库一体架构,统一管理结构化、半结构化与非结构化等多模态数据,一个系统承载事务处理、实时分析与 AI 工作负载。
OceanBase 数据库 V4.x 版本集群在恢复时,业务租户恢复完成,但是 CDB_OB_RESTORE_PROGRESS 视图显示 SYS 租户长时间处于 WAIT_TENANT_RESTORE_FINISH 状态不结束的原因和解决方法
更新时间:2026-05-13 07:31
问题现象
OceanBase 数据库 V4.x 版本集群在进行数据恢复时,通过 CDB_OB_RESTORE_PROGRESS 视图查看业务租户恢复完成,但是 SYS 租户长时间处于 WAIT_TENANT_RESTORE_FINISH 状态不结束,如下图所示。

且此时 RS 日志伴随着 -4012、-5627 异常,如下图所示。

关键日志信息 fail to create tenant end(ret=-5627,如下图所示。

问题原因
OceanBase 数据库集群在恢复租户过程中, OceanBase 数据库内部需要执行一些内部 SQL 获取信息,当 OceanBase 数据库内部 SQL 执行超时时, OceanBase 数据库内部会进行持续重试,此时会导致该问题。
问题的风险及影响
影响恢复进度,恢复卡住。
影响租户
影响 OceanBase 数据库中的 SYS 租户和 Oracle 租户以及 MySQL 租户。
适用版本
OceanBase 数据库 V4.x 版本。
解决方法及规避方式
解决方法:
调大
internal_sql_execute_timeout(设置系统内部 SQL 请求的时间间隔)参数。ALTER SYSTEM SET internal_sql_execute_timeout='1h';