基于湖库一体架构,统一管理结构化、半结构化与非结构化等多模态数据,一个系统承载事务处理、实时分析与 AI 工作负载。
OceanBase 数据库日志中出现 Fail to alloc data block, (ret=-4184)
更新时间:2024-01-22 01:56
问题现象
OceanBase 日志中出现如下错误。
Fail to alloc data block, (ret=-4184)
这个错误可能发生在磁盘空间不足的情况下,导致无法为数据分配新的数据块。
问题原因
磁盘可能存在问题,比如磁盘空间满,该异常会直接导致合并失败。
影响版本
OceanBase 数据库 V2.X 和 3.X 版本。
解决方法及
扩容磁盘。