基于湖库一体架构,统一管理结构化、半结构化与非结构化等多模态数据,一个系统承载事务处理、实时分析与 AI 工作负载。
无法卸载 NFS 备份目录
更新时间:2026-05-11 09:51
适用版本
OceanBase 数据库所有版本。
问题描述
卸载 NFS 备份目录时报错,提示错误信息如下。
unmount.nfs4: /ob_backup1: device is busy
问题原因
经排查,原因是 observer 进程占用了 NFS 的挂载目录。
fuser 目录,发现是 OBServer 进程占用,一般是不建议 kill 掉。

解决方法
由于无法 kill OBServer 进程,可以采用 umount -lf 命令来卸载磁盘。
这条命令意思是立即从目录结构中实现卸载,正在访问该文件系统的程序不受影响。即 OBServer 的进程不会被打断,且仍可以读写 /ob_backup 中的所有文件。如果所有进程对 /ob_backup 的操作都执行完,那么才真正地 umount。
lazy umount 并没有真正实现 umount,仅用于特殊需要的情况。