基于湖库一体架构,统一管理结构化、半结构化与非结构化等多模态数据,一个系统承载事务处理、实时分析与 AI 工作负载。
最后更新时间:2026-09-23 10:22:05
V4.3.6.8
版本信息
- 发布时间:2026 年 09 月 20 日
- 版本号:V4.3.6.8
主要变更
新增对 OceanBase 数据库 V4.2.5.8、V4.4.2.3 和 V4.6.0.1 的支持。
优化 Binlog 的日志转换和订阅链路性能,降低 CPU、I/O 和内存开销。
STOP BINLOG INSTANCE支持幂等处理。对已处于停止状态且不存在冲突生命周期任务的实例重复执行该命令时,将直接返回成功。更新 eTransfer 组件并优化 DDL 解析性能。
优化 LogProxy 同步性能。
缺陷修复
修复使用软链接目录部署时,LogProxy 已启动但状态检查结果异常的问题。
修复 MetaDB 密码包含特殊字符时,生成的 Binlog 配置文件格式错误,导致部署失败的问题。
修复
instances_gtid_seq表频繁写入和清理可能导致 MetaDB 查询超时的问题。修复主机内存缓存占用较高时,创建 Binlog 实例可能误报节点内存资源不足的问题。
修复 GBK 字符集下
SET和ENUM类型的数据经 Binlog 增量同步后可能不一致的问题。修复开启
binlog_ddl_convert后,增量 DDL 被 eTransfer 重复转换,导致解析耗时增加的问题。
V4.3.6.7
版本信息
- 发布时间:2026 年 08 月 10 日
- 版本号:V4.3.6.7
主要变更
新增对 OBCDC V5.0.1.0 的支持,可用于同步 OceanBase 数据库 V5.0.1.0 的数据。
适配 OBCDC V4.2.5.7 hotfix2 和 V4.3.5.6 hotfix2,支持从指定 Zone 拉取日志。
更新 eTransfer 至 V0.11.5。
缺陷修复
修复
SHOW BINLOG STATUS命令返回的磁盘占用率不准确的问题。修复 Binlog GTID 存在间断的问题。
修复
SHOW BINLOG EVENTS解析TABLE_MAP_EVENT时发生内存泄漏和元数据反序列化错误的问题。修复多节点场景下,
SHOW BINLOG INSTANCES误报Not found node且未返回节点信息的问题。修复 Binlog 指标重复上报的问题。
修复 mysqlbinlog 使用 GTID 非阻塞模式跨 Binlog 文件订阅时可能漏发数据的问题。
V4.3.6.6
版本信息
- 发布时间:2026 年 07 月 16 日
- 版本号:V4.3.6.6
主要变更
新增对 OBCDC V4.4.2.2 的支持。
创建 OBM 节点时支持更新 MetaDB 中节点的 slot 信息。
优化对 gh-ost 在线改表工具的兼容性,修复工具启动失败的问题。
缺陷修复
修复使用
ALTER BINLOG修改参数后,重启导致配置丢失的问题。修复 OBI 重启后下游订阅异常的问题。
修复克隆 Binlog 实例时元数据异常,导致无法生成数据的问题。
降低订阅线程的日志打印频率。
修复创建或重启 OBI 后,MetaDB 中的版本号仍为旧版本的问题。
V4.3.6.5
版本信息
- 发布时间:2026 年 06 月 29 日
- 版本号:V4.3.6.5
缺陷修复
- 修复 Binlog I/O 写放大限制软件性能上限的问题。
V4.3.6.4
版本信息
- 发布时间:2026 年 05 月 27 日
- 版本号:V4.3.6.4
缺陷修复
- 更新 eTransfer 组件,修复因组件版本过旧导致部分新增 OceanBase MySQL DDL 语法转换失败的问题。
V4.3.6.3
版本信息
- 发布时间:2026 年 05 月 09 日
- 版本号:V4.3.6.3
主要变更
新增对 OceanBase 数据库 V4.3.5.6、V4.6.0.0、V4.4.2.1 的支持。
支持 OBCDC V4.4.2.0 hotfix1 版本。
CREATE BINLOG FOR TENANT语法支持指定 slot。
缺陷修复
修复 OBI 内存膨胀导致 CDC 限流的问题。
优化
charset_encoding_bytes函数。修改
binlog_mode默认值为true。修复在 Rocky Linux 9.6 上创建 Binlog 集群后,为业务 MySQL 租户开通 Binlog 服务失败,报错
Error: 1236-HY000: Node resources are insufficient的问题。
V4.3.6.2
版本信息
- 发布时间:2026 年 03 月 09 日
- 版本号:V4.3.6.2
缺陷修复
- 修复
CREATE BINLOG FOR TENANT命令指定extra_obcdc_cfg选项时报语法分析错误的问题。
V4.3.6.1
版本信息
- 发布时间:2026 年 02 月 09 日
- 版本号:V4.3.6.1
缺陷修复
- 修复 Binlog 订阅异常影响业务的问题。
V4.3.6
版本信息
- 发布时间:2026 年 01 月 19 日
- 版本号:V4.3.6
主要变更
支持在 OBI 未拉起时,从 OBM 查询或修改 OBI 配置。
优化 Binlog 限速限流与监控数据:RPS 统计去除 Begin/Commit Event。
优化配置
throttle_convert_rps、throttle_convert_iops限制后,压数据位点推进但 RPS、IOPS 查询为 0 的问题。订阅连接断开后立即清理相关监控指标。
缺陷修复
优化转换延迟指标统计。
优化订阅延迟指标统计。
修复 OBI 启动失败,报错
failed to preprocess breakpoint binlog的问题。修复 LogProxy 主进程频繁异常退出的问题。
修复数据库名包含
-符号导致 MetaDB 初始化失败、OBM 部署失败的问题。修复不合法的订阅位点导致 OBI Core 的问题。
版本使用限制
OBProxy 社区版
V4.2.1 或更新版本
OceanBase 数据库社区版
详情请参阅下表,请注意支持范围包括早于最新支持版本的所有 BP 版本和 Hotfix 版本。
如果您使用的 OceanBase 数据库版本不在支持范围,通常情况下,您可以手动安装对应版本的 obcdc 依赖,使 Binlog 服务适配该版本。详情见 安装 obcdc。
| OceanBase 数据库版本序列 | 最新版 Binlog 支持的 OceanBase 数据库版本 |
|---|---|
| 3.2.x | V3.2.4 BP8 |
| 4.1.x | V4.1.0 BP4 |
| 4.2.x | V4.2.5 BP8 |
| 4.3.x | V4.3.5 BP6 |
| 4.4.x | V4.4.2 BP3 |
| 4.6.x | V4.6.0 BP1 |
| 5.0.x | V5.0.1.0 |